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Before we begin...

« Make sure you have ParaView 3.8.0 installed so you
can follow along in the lab section
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http://paraview.org/paraview/resources/software.html

Background

* Open-source, multi-platform parallel data analysis
and visualization application

« Mature, feature-rich interface
« (Good for general-purpose, rapid visualization
« Built upon the Visualization ToolKit (VTK) library

* Primary contributors:
— Kitware, Inc.
— Sandia National Laboratory
— Los Alamos National Laboratory
— Army Research Laboratory
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http://www.paraview.org/

Data Types

« Supports a wide variety of data types

— Structured grids

 uniform rectilinear, non-uniform rectilinear, and
curvilinear

— Unstructured grids
— Polygonal data

— Images

— Multi-block

— AMR

* Time series support
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Visualization Algorithms

e Supports a wide variety of visualization
algorithms
— |sosurfaces
— Cutting planes
— Streamlines
— Glyphs
— Volume rendering
— Clipping
— Height maps
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Special Features

Supports derived variables

— New scalar / vector variables that are functions of
existing variables in your data set

Scriptable via Python
Saves animations

Can run in parallel / distributed mode for large
data visualization
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Data Formats

« Supports a wide variety of data formats
— VTK (
— EnSight
— Plot3D
— Various polygonal formats

 Users can write data readers to extend
support to other formats

« Conversion to the VTK format is
straightforward

TRCC


http://www.vtk.org/VTK/img/file-formats.pdf
http://www.vtk.org/VTK/img/file-formats.pdf
http://www.vtk.org/VTK/img/file-formats.pdf

Data Formats

# vtk DataFile Version 2.0

e VTK S| mple Leg acy Really cool data @

ASCIL | BINARY @)
Format DATASET fype

° ASCI I Or blnary POINT DATA n

CELL DATA n

(4)

(5)

e Supports all VTK

Part 1: Header Part 4: Geometry/topology. Type is one of:

grid types

 Easiest for data
. nated with newline \n character) iigg;ig;ﬁgﬁ;fzégn}
conversion -

Part 3: Data type, either ASCII or BINARY POLYDATA
RECTILINEAR GRID

FIELD

PY N Ote : use VT K X M L Part 5: Dataset attributes. The number of data

items 1 h type must match the number

fo rm at for paral I eI I/O of points or cells in the dataset. (If fype is

Part 2: Title (256 characters maximum, termi-

VTK simple legacy format ( )

FIELD, point and cell data should be omitted.


http://www.vtk.org/VTK/img/file-formats.pdf
http://www.vtk.org/VTK/img/file-formats.pdf
http://www.vtk.org/VTK/img/file-formats.pdf

Data Formatting Example

« Data set: 4x4x4 rectilinear grid
with one scalar variable

# vtk DataFile Version 2.0

one scalar variable on a rectilinear grid
ASCII

DATASET RECTILINEAR_GRID

DIMENSIONS 4 4 4

X_COORDINATES 4 float

®12.54.5

Y_COORDINATES 4 float

0246

Z_COORDINATES 4 float

@369

POINT_DATA 64

SCALARS scalar_variable float 1
LOOKUP_TABLE default
012345678910 11 12 13 14 15 16
17 18 19 20 21 22 23 24 25 26 27 28 29 30
31 32 33 34 35 36 37 38 39 40 41 42 43 44
45 46 47 48 49 50 51 52 53 54 55 56 57 58
59 60 61 62 63
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ParaView Visualization Pipeline

 All processing operations (filters) produce
data sets

« Can further process the result of every
operation to build complex visualizations

— e.g. can extract a cutting plane, and apply glyphs
(l.e. vector arrows) to the result

« Gives a plane of glyphs through your 3D volume
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Demonstration

 WRF weather forecast data set
— Rectilinear grid
— Multiple scalar and vector variables
— Time series

« Can show:
— Clouds
— Wind
— Temperature

TRCC



A4 ParaView 3.8.0

)

Pipeline Browser

B builtin:
» B0 wrf_small-*
@ |-® Contourl
1 Slicel
@ | @ WarpByScalarl
@ =@ Calculatorl
» @ Slice2
@ W@ Glyphl

Objectinspector @
| Properties Display Information ]

Statistics

Type: Rectilinear
Number of Cells: 160512
Number of Points: 171787
Memory: 8.1 MB

Data Arrays
Current data time step: 0

Name Data Type Data Ranges

o XLAND float [-999, 2]

u float [-11.2548, 51.2167]

v float [-24.9953, 33.9401]
w float [-0.433493, 0.331888]
P float [-996.754, 2249.68]
QVAPOR float [-7.19474e-05, 0.01877
QCLOUD float [0, 0.000696224]
QRAIN float [0, 0.000945338]

T2 float [-999, 303.211]

HGT float [-999, 3232.91]

s

000000000
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Getting Started

 Download example data file ‘RectGrid2.vtk’
— http://portal.longhorn.tacc.utexas.edu/training/
— Right-click, Save link as...

* Open ParaView
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ParaView

Today we will:
« Create isosurfaces for a scalar
variable

« Clip and slice the isosurfaces

* Use glyphs to display a vector
field

 Use streamlines to show flow
through a vector field

« Edit color maps

 Add slices to show variable
values over a plane

» Adjust opacities of filters
« Add color legends
* Create volume rendering
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ParaView

Open the file
RectGrid2.vtk

e Click File -> Open

« SelectRectGrid2.vtk | e
* Click ok

» Click blue rpply

* Box outline of dataset
extent displayed

Pipeline Browser
. £ Open File:

Sbje
Properties Desktop

&= a7+ Files of type: [ Supported Files (*.pop.ncdf *.pop icles =.ncdf *.netcdf
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ParaView

Open the file
RectGrid2.vtk

e Click File -> Open
 SelectRectGrid2.vtk
» Click oK

* Click blue 2pply

 Box outline of dataset
extent displayed
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ParaView

Open the file
RectGrid2.vtk

e Click File -> Open
 SelectRectGrid2.vtk
» Click oK

» Click blue 2pply

 Box outline of dataset
extent displayed
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ParaView

Create isosurfaces

o CliCk Filters _> - '_'“":"':‘ . ‘CnnAmur 0
Common -> Contour : Ao :

* |n Isosurfaces box, click
Delete All

* Click New Range e
« Keep defaults, click Ok
» Click blue 2pply

 Click Displaytab

* InColor by box, select
vectors
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ParaView

Create isosurfaces

e Click Filters ->
Common —-> Contour

* |n Isosurfaces box, click
Delete All

 Click New Range

» Keep defaults, click Ok
» Click blue 2pply
 Click Displaytab

 InColor by box, select
vectors

TRCC



ParaView

Create isosurfaces

e Click Filters ->
Common —-> Contour

* |n Isosurfaces box, click
Delete All

 Click New Range

» Keep defaults, click Ok
» Click blue 2pply
 Click Displaytab

* InColor by box, select
vectors

TRCC



ParaView

Create isosurfaces

e Click Filters ->
Common —-> Contour

* |n Isosurfaces box, click
Delete All

 Click New Range

» Keep defaults, click Ok
* Click blue 2pply
 Click Displaytab

* InColor by box, select
vectors
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ParaView

Create isosurfaces

e Click Filters ->
Common —-> Contour

* |n Isosurfaces box, click
Delete All

 Click New Range

» Keep defaults, click Ok
» Click blue 2pply
 Click Displaytab

* InColor by box, select
vectors

TRCC



ParaView

Create isosurfaces

e Click Filters ->
Common —-> Contour

* |n Isosurfaces box, click
Delete All

 Click New Range

» Keep defaults, click Ok
» Click blue 2pply
 Click Displaytab

* InColor by box, select
vectors

TRCC



ParaView

Create isosurfaces

e Click Filters ->
Common —-> Contour

* |n Isosurfaces box, click
Delete All

 Click New Range

» Keep defaults, click Ok
» Click blue 2pply
 Click Displaytab

* InColor by box, select
vectors

TRCC



ParaView

Clip isosurfaces
* Click +Y view button

e ClickFilters ->
Common —-> Clip

® ParaView File Edit View Sources Filters Tools Macros Help @ KD - O @08 Thu7:00PM karla Q

« Drag arrow point around
to front of surface (arrow
turns red when selected)

» Click blue 2pply

e Click Inside Out
checkbox
» Click blue 2pply

e Click show Center

button to remove
crosshairs
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ParaView

Clip isosurfaces
« Click +Y view button

e Click Filters ->
Common -> Clip

)  (2:36) Thu6:34PM  karla Q

« Drag arrow point around
to front of surface (arrow
turns red when selected)

* Click blue 2pply

e Click Inside Out
checkbox
* Click blue 2pply

e Click show Center

button to remove
crosshairs

TRCC



ParaView

Clip isosurfaces
« Click +Y view button

e ClickFilters ->
Common —-> Clip

« Drag arrow point around
to front of surface (arrow
turns red when selected)

* Click blue 2pply

e Click Inside Out
checkbox
» Click blue 2pply

e Click show Center

button to remove
crosshairs

TRCC



ParaView

Clip isosurfaces
« Click +Y view button

e ClickFilters ->
Common —-> Clip

« Drag arrow point around
to front of surface (arrow
turns red when selected)

» Click blue 2pply

e Click Inside Out
checkbox
* Click blue 2pply

e Click show Center

button to remove
crosshairs

TRCC



ParaView

Clip isosurfaces
« Click +Y view button

e ClickFilters ->
Common —-> Clip

@:19) Thu6:36PM karla Q

« Drag arrow point around
to front of surface (arrow
turns red when selected)

» Click blue 2pply

e Click Inside Out
checkbox
» Click blue 2pply

e Click show Center

button to remove
crosshairs

TRCC



ParaView

Slice isosurfaces
« Clickeyenextto Clipl
to hide clip plot

 Click Contourl in
Pipeline Browser

e Click Filters ->
Common -> Slice

@ KO - OO0 @24 Thu6:36PM karla Q

« Drag arrow point around
to front of surface (arrow
turns red when selected)

* Click blue 2pply
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ParaView

Slice isosurfaces
« ClickeyenexttoClipl
to hide clip plot

 Click Contourl In
Pipeline Browser

e Click Filters ->
Common -> Slice

) F 2:05) Thu6:37PM _karla Q

« Drag arrow point around
to front of surface (arrow
turns red when selected)

* Click blue 2pply

TRCC



ParaView

Slice isosurfaces
« ClickeyenexttoClipl
to hide clip plot

 Click Contourl in
Pipeline Browser

e Click Filters ->
Common -> Slice

« Drag arrow point around
to front of surface (arrow
turns red when selected)

* Click blue 2pply

TRCC



ParaView

Slice isosurfaces
« ClickeyenexttoClipl
to hide clip plot

 Click Contourl in
Pipeline Browser

e Click Filters ->
Common -> Slice

« Drag arrow point around
to front of surface (arrow
turns red when selected)

* Click blue 2pply

TRCC



ParaView

Slice isosurfaces
« ClickeyenexttoClipl
to hide clip plot

 Click Contourl in
Pipeline Browser

e Click Filters ->
Common -> Slice

« Drag arrow point around
to front of surface (arrow
turns red when selected)

* Click blue 2pply

TRCC



ParaView

Slice isosurfaces
« ClickeyenexttoClipl
to hide clip plot

 Click Contourl in
Pipeline Browser

e Click Filters ->
Common -> Slice

« Drag arrow point around
to front of surface (arrow
turns red when selected)

» Click blue 2pply

TRCC



ParaView

Create Glyph of Vector Field
* Click RectGrid2.vtk
In Pipeline Browser

e ClickFilters ->
Common -> Glyph

* Click blue 2pply

@ ParaView File Edit View Sources Filters Tool

TRCC



ParaView

Create Glyph of Vector Field

e Click RectGrid2.vtk
In Pipeline Browser GADAEE 00 e o] TR T—

Data Analysis @ Clip
) S olor Statistics Slice
- l Temporal “4 Threshold
e Click Filters -> soes '
ipel ]

Stream Tracer
B builtin

Common -> Glyph 8 o
* Click blue 2pply

® clipl
@ L Slicel

Properties Information

TRCC



ParaView

Create Glyph of Vector Field
* Click RectGrid2.vtk
In Pipeline Browser

e ClickFilters ->
Common -> Glyph

* Click blue 2pply

@& :10) Thu6:39PM karla Q

Properties

(7 Apply )

Scalars

Vectors [ vectors

Glyph Type [ Arrow

Arrow

N - S
Resolution

Tip Radius

Tip Length

Shaft
Resolution

Shaft

TRCC



ParaView

Create Glyph of Vector Field
* Click RectGrid2.vtk
In Pipeline Browser

e ClickFilters ->
Common -> Glyph

* Click blue 2pply

@& 2:18) Thu6:39PM karla Q

Properties

Scalars

Vectors [ vectors

Glyph Type [ Arrow

Arrow

AP (6

Resolution

Tip Radius

Tip Length

Shaft
Resolution

Shaft

TRCC



ParaView

Create Streamlines

* Click eye nextto Glyphl
to hide glyph plot

* Click RectGrid2.vtkin
Pipeline Browser

e Click Filters ->

Common ->
Stream Tracer

* Click blue 2pply

« Under Display tab, in
the Color by box,
select Vorticity

@ ParaView File FEdit View Sources Filters Tool D s W } 2:18) Thu6:39PM  karla Q
[ NeNe) -

TRCC



ParaView

Create Streamlines

* Click eye nextto Glyphl
to hide glyph plot

 Click RectGrid2.vtkin
Pipeline Browser

e Click Filters ->
Common ->
Stream Tracer

* Click blue 2pply

« Under Display tab, in
the Color by box,
select Vorticity

TRCC



ParaView

Create Streamlines

* Click eye nextto Glyphl
to hide glyph plot

e Click RectGrid2.vtkin
Pipeline Browser

e Click Filters ->
Common ->
Stream Tracer

* Click blue 2pply

« Under Display tab, in
the Color by box,
select Vorticity

) F 2:24) Thu6:40PM karla Q
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ParaView

Create Streamlines

* Click eye nextto Glyphl
to hide glyph plot

e Click RectGrid2.vtkin
Pipeline Browser

e Click Filters ->
Common ->
Stream Tracer

* Click blue 2pply

« Under Display tab, in
the Color by box,
select Vorticity

@ ParaView File FEdit View Sources Filters Tool D s W } 2:24) Thu6:40 PM_ karla Q
[ NeNe) -

TRCC



ParaView

Create Streamlines

* Click eye nextto Glyphl
to hide glyph plot

e Click RectGrid2.vtkin
Pipeline Browser

e Click Filters ->
Common ->
Stream Tracer

* Click blue 2pply

« Under Display tab, in
the Color by box,
select Vorticity

@ ParaView File FEdit View Sources Filters Tool D s W } (2:16) Thu 6:40 PM  karla Q
[ NeNe) -

TRCC



ParaView

Create Streamlines

* Click eye nextto Glyphl
to hide glyph plot

e Click RectGrid2.vtkin
Pipeline Browser

e Click Filters ->
Common ->
Stream Tracer

* Click blue 2pply

« Under Display tab, in
the Color by box,
select Vorticity

@ ParaView File FEdit View Sources Filters Tool D s W } (2:16) Thu 6:40 PM  karla Q
[ NeNe) -

TRCC



ParaView

Create Streamlines

* Click eye nextto Glyphl
to hide glyph plot

e Click RectGrid2.vtkin
Pipeline Browser

e Click Filters ->
Common ->
Stream Tracer

* Click blue 2pply

« Under Display tab, in
the Color by box,
select Vorticity

@ ParaView File FEdit View Sources Filters Tool D s W } 2:22) Thu6:41PM  karla Q
[ NeNe) -

TRCC



ParaView

Create Tubes

« Click streamTracerl
In Pipeline Browser

e Click Filters ->

ParaView File Edit View Sources Filters Tools Macros

| Surface

Alphabetical -> B

=8 Contourl

@ Clipl

Tube e
* Click blue 2pply

Stream Tracer

Vectors

Vector Interpolator Type
Integration Direction
Integrator Type
Integration Step Unit
Initial Step Length

Minimum Step Length

T———

TRCC



ParaView

Create Tubes
ParaView File Edit View Sources 4) Wed 5:14PM _ karla Q

 Click StreamTracerl
in Pipeline Browser e RN

Data Analysis
I Statistics A Python Calculator
Temporal Quadric Clustering

« ClickFilters -> . T

Pipeline Br Bafiect
— Resample With Dataset

U B builtin: Ribbon
A abetica -> o ® reccrid Rotational Exruson
Scatter Plot

» =@ Contourl

Shrink
Slice
Tube o
® Glyphl Stream Tra
) StreamTracerl Stream Tracer With Custom Source
Subdivide
[l 1 Properties- |INSESISE - Information-| Surface Flow
e Clic ue Apply - e

M Visible Zoom To Data

Temporal Cache

Temporal Interpolator

Color Temporal Shift Scale

Temporal Snap-to-Time-Step

Temporal Statistics

Tessellate

Cielhy e Tetrahedralize

Texture Map to Cylinder

Texture Map to Plane

Texture Map to Sphere
Threshold

Transform

Triangle Strips

Slice Direction Triangulate

# Selectable

[ Interpolate Scalars

Color by

Warp By Scalar
Warp By Vector
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ParaView

Create Tubes
e Click StreamTracerl -
In Pipeline Browser X 5 2 | RN T —

e ClickFilters ->
Alphabetical ->
Tube g L

* Click blue 2pply

Scalars

Vectors | Norm:

Number ]
of Sides

# capping
Radius | 0.00: 182148551

vay e
Radws (OF 9
Radius

0
Factor 0

["1Use Default Normal

Default
Normal

TRCC



Create Tubes

ParaView

e Click streamTracerl

In Pipeline Browser

e ClickFilters ->
Alphabetical ->
Tube

* Click blue 2pply

Edit View Sources Filters Tools Macros Help

| Surface

» =@ StreamTracerl
©) Tubel

Dbje
% Delete

Scalars
Vectors | Norm:

Number ]
of Sides

# capping
Radius | 0.00: 182148551

vay e
Radws (OF 9
Radius

0
Factor 0

["1Use Default Normal

Default
Normal

Time

15PM karla

Q

TRCC



ParaView

Edit Color Map
» Click Edit Color Map
 Click Choose Preset

« SelectBLUE...HSV
* Click blue oK o —_—

B Slicel

Adium File Edit View Status Contact Format ndow Help 43) Wed 5:15PM karla Q

| Surface

{"Color Seale __Color Legend |

Scalar Value 0 Opacity

« Click blue Close I ——

] Use Logarithmic Scale
utomatically Rescale to Fit Data Range
Zoom To Data Minimum: 0 Maximum: 9.45285

ale to Data Range Rescale to Temporal Range

¥ Interpolate Scalars (¥ Use Discrete Colors
Resolution

Apply Texture

Color by —————
Make Default
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ParaView

Edit Color Map
« Click Edit Color Map
 Click Choose Preset

« SelectBLUE...HSV
* Click blue oK o —_—

B Slicel

Adium File Edit View Status Contact Format ndow Help 43) Wed 5:15PM karla Q

| Surface

{"Color Seale __Color Legend |

Scalar Value 0 Opacity

« Click blue Close I ——

] Use Logarithmic Scale
utomatically Rescale to Fit Data Range
Zoom To Data Minimum: 0 Maximum: 9.45285

ale to Data Range Rescale to Temporal Rdnge )

¥ Interpolate Scalars (¥ Use Discrete Colors
Resolution

Apply Texture

Color by —————
Make Default

TRCC



ParaView

Edit Color Map

« Click Edit Color Map

* Click Choose Preset
« Select BLUE. . .HSV e

RectGrid2.vtk

* Click blue ox > g —_—

ParaView File Edit View Sources Filters Tools Macros Help 43) Wed 5:15PM karla Q

cale Color Legend |

80n0 44 Preset Color Scales
_ Scalar Val
® Glyph1
- » =@ StreamTracerl Name - =1
[ J @ @ Tubel Cool... Diverging |
[ ue ose —

Informa ); Red HSV
Gray... RGB

W visible Zoom To Data - Blue ... RGB
Blac... RGB

oK

=

¥ Selectable

Cancel

¥ Interpolate Scalars

—_——0 556

Apply Texture

Color by -
Make Default

sl
Slice Direction
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ParaView

Edit Color Map

« Click Edit Color Map
e Click Choose Preset
e SelectBLUE...HSV e

 builtin:
1 2@ F.e=:(Crid2‘Tnk -—-
* Click blue oK

e A4 Preset Color Scales

ParaView File Edit View Sources Filters Tools Macros Help
A ParaView

Scalar Val

Colorspace | ( Impor

° =@ StreamTracerl Cool... Diverging D—
IC ue ose s |~ B

Red ... HSV
Gray... RGB
Blue ... RGB
Blac... RGB
CIEL... CIELAB

Informa

View . 2 oK 3
¥ Visible Zoom To Data Cancel

o
V' Selectable Resolution = () 256

¥ Interpolate Scalars
Make Default )

Apply Texture

Color by
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ParaView

Edit Color Map

« Click Edit Color Map

* Click Choose Preset
« Select BLUE. . .HSV

» Click blue OK

 Click blue Close

Edit

Pipeline Broy

@ B RectCrid2 vtk

Contourl
@ Clipl
B Slicel

® Glyph1

¥ Interpolate Scalars

Apply Texture

Color by ( la

View Sources Filters Tools 43) Wed 5:16 PM _ karla

44 Color Scale Editor

[ Color Scale | Color Legend |

K

Scalar Value 0 Opacity

Color Space | HSV

7] Use Logarithmic Scale
™ Automatically Rescale to Fit Data Range
Zoom To Data Minimum: 0 Maximum: 9.45285
ale to Data Range Rescale to Temporal Range

¥ Use Discrete Colors

Resolution = )

" Make Default ) (“€lose )

Edit Color Map... )

Q
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Edit Color Map

Click Edit Color Map
Click Choose Preset

Select BLUE. . .HSV

Click blue ok
Click blue Close

ParaView

Edit View Sources Filters Tools Macros Help

| Surface

» £ StreamTracerl

©) Tubel

Zoom To Data

M Selectable

Color

[ Interpolate Scalars

Apply Texture

Color by

Slice Direction

Time

)

16 PM karla

Q
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ParaView

Create Slice
e Click RectGrid2.vtk
In Pipeline Browser

e Click Filters ->
Common -> Slice

= 4 (& (0:52) Wed 6:08 PM karla Q

« Drag arrow point around
to front of surface (arrow
turns red when selected)

e Orclick Y Normal
* Click blue 2pply
e Click Show Plane

TRCC



ParaView

Create Slice

Click RectGrid2.vtk
In Pipeline Browser

Click Filters ->
Common -> Slice

ile Edit View Sources Filters Tool

Drag arrow point around
to front of surface (arrow
turns red when selected)

Orclick Y Normal
Click blue rpply
Click Show Plane

Gk (0:51)

) Wed 6:08 PM_karla Q
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ParaView

Create Slice

Click RectGrid2.vtk
In Pipeline Browser

Click Filters ->
Common -> Slice

ile Edit View Sources

Drag arrow point around
to front of surface (arrow
turns red when selected)

Orclick Y Normal
Click blue Apply
Click Show Plane

Gk (0:51)

) Wed 6:09PM karla Q
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ParaView

Create Slice

Click RectGrid2.vtk
In Pipeline Browser

Click Filters ->
Common -> Slice

ile Edit View Sources

Drag arrow point around
to front of surface (arrow
turns red when selected)

Orclick Y Normal
Click blue rpply
Click Show Plane

QR D 32 T 0 &4

) Wed 6:15PM karla Q
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ParaView

Create Slice
e Click RectGrid2.vtk
In Pipeline Browser

e Click Filters ->
Common -> Slice

G KR DO 32 = 0 045 Wed6:l5PM karla Q

« Drag arrow point around
to front of surface (arrow
turns red when selected)

e Orclick Y Normal
* Click blue 2pply
e Click Show Plane

TRCC



ParaView

Background Color

 C(Click the @ button above
the 3D view

e Click Choose Color
« Drag box to black

@ Clipl

Pipeline Brow

licel

* Click blue ok 3

@ LW slice2

» Click blue 0k

% Delete

| Plane

0.02420304

nds

Z Normal

Camera Normal er on Bound:

Slice Offset Values

TRCC



ParaView

Background Color

e Click the @ button above
the 3D view

e Click Choose Color
e D rag box to black -¢ t R
* Click blue 0k

) Tubel
0 Slice2

 Click blue 0k -

& Delet

ParaView File Edit View Sources Filters Tools Macros Help 3) Wed 6:16 PM  karla Q

Pipeline Bre L View Settings (Render View)

| Plane

0.44¢
Normal 0.0311 3/0.02¢4

X Normal

Camera Normal Center on Bounds

Slice Offset Values
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ParaView

Background Color

e Click the @ button above
the 3D view

e Click Choose Color

[} D rag bOX to b | aC k l t izlégl‘ji,ﬂ“ o : Salid Color T o Epu—
. Le: O = O Gradient Color —

e Click blue 0k

 Click blue 0k

ParaView File Edit View Sources Filters Tools Macros Help 3) Wed 6:17PM  karla Q
A ParaView

Pipeline Bre

0 Slice2

| Plane

( Cancel

Normal 0.0311 2053/ 0.02

X Normal

Camera Normal Center on Bounds

Slice Offset Values
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ParaView

Background Color

e Click the @ button above
the 3D view

e Click Choose Color
« Drag box to black

® Clipl
W Slicel

* Click blue 0k

0 Tubel
) slice2

» Click blue 0k

! Properties  Display  Informi

Slice Type

Cancel

Reset Bouna

Z Normal

( Camera Normal er on Bounds

Slice Offset Values

Solid Color
Gradient Color
Background Image

Use Parallel Projection

@ Choose Color

TRCC



ParaView

Background Color

e Click the @ button above
the 3D view

« Click Choose Color
« Drag box to black

* Click blue 0Ok

* Click blue 0k

A built

@ B RectGrid2 vtk

©al

= StreamTracerl
®
e

Tubel
Slice2

¢ Delete

Normal 0.031f
X Ne

( Camera Normal Center on Bounds

Slice Offset Values

8PM karla

rar
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ParaView

Object Opacity

 Click slice2 in Pipeline
Browser

 Click Display

« Change Opacity to
0.70 => Enter

* Click Color by vectors

« Click eye next to
RectGrid2.vtk to hide
box outline

TRCC



ParaView

Object Opacity

 Click sSlice2 in Pipeline
Browser

* Click Display

« Change Opacity to
0.70 -> Enter

* Click Color by vectors

« Click eye next to
RectGrid2.vtk to hide
box outline

TRCC



ParaView

Object Opacity

 Click sSlice2 in Pipeline
Browser

* Click Display

« Change Opacity to
0.70 => Enter

* Click Color by vectors

« Click eye next to
RectGrid2.vtk to hide
box outline

TRCC



ParaView

Object Opacity

 Click sSlice2 in Pipeline
Browser

* Click Display

« Change Opacity to
0.70 => Enter

* Click Color by vectors

» Click eye next to
RectGrid2.vtk to hide
box outline

TRCC



ParaView

Object Opacity

 Click sSlice2 in Pipeline
Browser

* Click Display

« Change Opacity to
0.70 => Enter

* Click Color by vectors

« Click eye next to
RectGrid2.vtk to hide
box outline
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ParaView

Enable Color Legend

Click Display
Click Edit Color Map
Click Color Legend

Click show Color
Legend

Click => Blue Close

Select Color Legend
(notice white rectangle)
and move to top of 3D
viewer

i buil
» ) RectGrid2 vtk
=@ Contourl
® Clipl
@ Slic

0 Tubel
) slice2

Proper

Color by

Slice Direction
s

Annotation

] Show cube axes

Style

Scalar Value 0

Color Space | Diverging

["] Use Logarithmic Scale

[ Automatically Rescale to Fit Data Range

Minimum 0 Maximum:

™ Use Discrete Colors

10.3964
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ParaView

Enable Color Legend
» Click Display

* ClickEdit Color Map |[EEEEEESENE: T
 Click Color Legend ﬁ ‘ SR

[ Color Scale | Color Legend |

* Click Show Color iy

Text
Font
Legend e i o
l’ Tubel T
o @ WD Slice2
e Click => Blue Close

. m v Size 12 Z Opacity 0.00
Propertie play  Information (=R

Label Format
Color by

« Select Color Legend sy Gl | e
(notice white rectangle) [EEEE— —p—

and move to top of 3D
viewer *
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ParaView

Enable Color Legend

Click Display

Click Edit Color Map |EEEEIEEEEN I —
Click Color Legend X - —
Click show Color s

Text |vectc Magnitude

P g Font ]
L = g =2t d li T;::TT"““'I 3= acivg L vectors Magni
. @ L@ siice2 = ]_?03964
Click -=> Blue Close :

} iz 2 [ i C
Propertie Information Size J GpeEg) 100 7.5

¥ Automatic Label Format Label Format 6
Color by 5

Select Color Legend e [ g
(notice white rectangle) [EEEE— = —

and move to top of 3D
viewer
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ParaView

Enable Color Legend

» Click Display

» ClickEdit Color Map
 Click Color Legend

e Click show Color
Legend

e Click -=> Blue Close

« Select Color Legend
(notice white rectangle)
and move to top of 3D
viewer

ors Magni
10.3964
10

75

5

25

0
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ParaView

Enable Color Legend

» Click Display

» ClickEdit Color Map
 Click Color Legend

 Click Show Color teme 25
Legend = eomn

e Click -=> Blue Close

« Select Color Legend
(notice white rectangle)
and move to top of 3D
viewer
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ParaView

Create Volume Rendering

 Click RectGrid2.vtk
In Pipeline Browser s T —

Cosmolo H
3y Programmable Filter

Data Analysis
Statistics y Python Calculator

« Click Filters -> e o o o e

Reflect

C O mm O n > s Resample With Dataset
- @ builtin

RectGrid2 vtk
Scatter Plot
Shrink

Tetrahedralize | fes .

Stream Tracer
Stream Tracer With Custom Source

 Click -> Apply - o s,

Object Inspector (X ]
- a Properties splay | Information | Temporal Cache
[ ] ‘ | IC k D l S l a Apply Texture Temporal Interpolator
p y Temporal Shift Scale
Color by [ @5olid Color 14 | ) Temporal Snap-to-Time-Step
‘ Temporal Statistics

Set Ambient Color... | Tessellate

 Click Representation [® s —
 Select Volume

e Click -=> Edit Color
Map (To edit
transfer function)
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ParaView

Create Volume Rendering
* Click RectGrid2.vtk

@  ParaView File FEdit View Sources el D = <7 4 (=l (Charged) Mon 1:59PM karla Q

In Pipeline Browser
e Click Filters -> —
C ommon - > _ 3 bl \ vectors Magnitude
S e o 25 5 7.5
Tetrahedralize

 Click -> 2Apply
 Click Display

 Click Representation
» Select volume

e Click -=> Edit Color
Map (To edit
transfer function)
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ParaView

Create Volume Rendering
 Click RectGrid2.vtk
In Pipeline Browser

e Click Filters -> u

C ommon - > & \ vectors Magnitude

, > &8 Co 25 5 7.5
Tetrahedralize

 Click -> 2Apply
* Click Display

@  ParaView File FEdit View Sources el 9 = <7 4 (=l (Charged) Mon 2:00 PM karla Q

 Click Representation
» Select Volume

e Click -=> Edit Color
Map (To edit
transfer function)
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ParaView

Create Volume Rendering
 Click RectGrid2.vtk
In Pipeline Browser

e Click Filters ->
Common ->
Tetrahedralize

 Click -> 2Apply
* Click Display

(Charged) Mon 2:00 PM _karla Q

 Click Representation
 Select Volume

e Click -=> Edit Color
Map (To edit
transfer function)
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ParaView

Create Volume Rendering
 Click RectGrid2.vtk
In Pipeline Browser

e Click Filters ->
Common ->
Tetrahedralize

 Click -> 2Apply
* Click Display

(Charged) Mon 2:01PM karla Q

 Click Representation
 Select Volume

e Click -=> Edit Color
Map (to edit
transfer function)
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w_File Edit View Sources Filters Tools Macros Help

4 ParaView 3.8.0
3

> vectors #] [ Magnitude 8] [ Surface

vectors Magnitude
25 5 7.5

@ Tubel
) Slice2

Object Inspector 20
Display | _Information
Color by © vectors #) [Magnitu

-
Edit Color Map. Rescale to Data Ra

[XeXs)

File Edit View Sources Filters Tools Macros _Help
4 ParaView 3.8.0 O
ties - Display
2) § x W1 Interpolats lars

> vectors Magnitude

& | Apply Texture

Color by > scalars

Color Map.

@ -4 Contourl
@ Clipl

ct Inspectos 20

Properties | Display . _Information

™ visible Zoom To Data

View m
|
g

¥ Selectable

™ interpolate Scalars

Apply Texture
Color by o vectors Magnitu
olor M

@& 04D

Rescale to Data R

Thu 10:53 AM_karla_Q

@& ParaView File Edit View Sources Filters Tools Macros Help
faNO

3

> scalars

Pipeline Browser

ectinspecto
Propertes IBieplayel Information
Color by © scalars |

Edit Color Map. Rescale to Data R;:’
Fiters_ Tools _Macros _Help @ B O & 4 = Chaes Mon201PM_karla
4 ParsView 3.8.0

vectors Magnitude
5 5 7.5

Help

ct Inspecto X}
Properties | Display-|_Information
View n
™ visible 'oom To Data |
Visib Zoom To Dat )
¥ Selectable

c

# interpolate Scalars

Apply Texture

Color o vectors & | Magnitu
ot e to Data F

€ ] <

4 ParaView 3.8.0

4 ParaView 3.8.0

@ 037)

Thu 1053 AM_
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Questions?

« More tutorials available:

TRCC


http://www.paraview.org/Wiki/The_ParaView_Tutorial

